System Requirements

 

LastPass supports the below web browsers, operating systems and mobile devices.

 


 

Operating Systems

 

  • Windows XP
  • Windows Vista
  • Windows 7
  • Windows 8.1
  • Mac OS X 10.7+
  • Linux

 

Web Browsers

 

 

Mobile Devices (Premium and Enterprise Only)

 

 


 

Previous Platforms

 

We have previously built versions of LastPass for platforms that we no longer develop for. Users are welcome to install and use them, but we cannot offer technical support for these versions.

 

 

Users are strongly recommended to download and run the installer from our website on all browsers you regularly use.